Losing My Head

Discuss anything about animation, art and drawing.
User avatar
QuinB
Posts: 12
Joined: Tue Feb 20, 2018 7:11 pm

Losing My Head

Postby QuinB » Thu Jul 05, 2018 9:56 am

Hi All,

I'm having a difficulty with the Curve Warp distortion.
After adding a midpoint to the to the
I'm setting up four keyframes for this test at 'nail bent left', 'nail vertical', 'nail bent right', 'nail vertical' and letting Synfig get on with the details.
The result is that the nail head is lost, warping out of view.
Can anybody suggest better methods or settings to avoid the problem, please?
More keyframes/waypoints, perhaps?
Run the nodes along splines?
Stop being lazy, work out the animation in terms of sine curves and let Synfig calculate the movement completely?
All the best
QuinB

Image

User avatar
bazza
Posts: 196
Joined: Mon May 23, 2016 10:48 am
Location: Argentina
Contact:

Re: Losing My Head

Postby bazza » Thu Jul 05, 2018 10:23 am

Your can increase the size of the area work origin and final

User avatar
QuinB
Posts: 12
Joined: Tue Feb 20, 2018 7:11 pm

Re: Losing My Head

Postby QuinB » Thu Jul 05, 2018 11:00 am

Does Synfig take into account the 'room' around the sections being interpolated in its choice of paths?

User avatar
bazza
Posts: 196
Joined: Mon May 23, 2016 10:48 am
Location: Argentina
Contact:

Re: Losing My Head

Postby bazza » Thu Jul 05, 2018 12:12 pm

I do not understand a lot english.
I have attained good results using an area initiate big area and the distorción and errors are lower

Image
Attachments
2018-07-05-121110_745x529_scrot.png
idea

User avatar
QuinB
Posts: 12
Joined: Tue Feb 20, 2018 7:11 pm

Postby QuinB » Thu Jul 05, 2018 6:00 pm

I see!
Thanks for the clarification - that helps a lot.

You might not know a great deal of English, but you have more than I do of any second or third language (I do better with machine language than human - it's not like I haven't tried). Thanks for taking the time and effort to explain.

Cheers
Q

User avatar
QuinB
Posts: 12
Joined: Tue Feb 20, 2018 7:11 pm

Re: Losing My Head

Postby QuinB » Sun Jul 08, 2018 3:19 pm

I'd post pictures, but using the img tag results in a message stating that the post has too few characters - which, technically, it does, because the act of posting deletes the content, however I'm wise to that one after trying to start the thread and simply write the text beforehand in an editor before posting it to the page.

So.
A better result - thanks.
Not perfect, but definitely BETTER.

I tried various methods, but found most controllability by linking the warp curve tip and related tangent handle to a spline arc.
Interestingly, the arc is not a perfect circle.
I briefly experimented with the using converters to control the angle of the tangent handle, but eventually found it simpler to increase the size of the warp curve rig to the amount shown below and let the tangent handle sit at a constant angle to the spline arc as it progresses.

Also interestingly, I found that, even if the spline arc is deleted, the linked warp curve tip still follows the line of the non-existent arc.

User avatar
BobSynfig
Posts: 322
Joined: Sat Aug 15, 2015 6:08 am

Re: Losing My Head

Postby BobSynfig » Sun Jul 08, 2018 4:19 pm

[quote=QuinB]I'd post pictures, but using the img tag results in a message stating that the post has too few characters - which, technically, it does, because the act of posting deletes the content[/quote]
Please avoid URL shortener and use a direct link to your image on your site or using a hosting service.
URL Shorteners (bit.ly in your case) are the cancer of the internet https://en.wikipedia.org/wiki/URL_shortening
Always check first! - Use last builds only: Stable 1.2.1 /
- - - Google Translate may help

User avatar
QuinB
Posts: 12
Joined: Tue Feb 20, 2018 7:11 pm

Re: Losing My Head

Postby QuinB » Sun Jul 08, 2018 4:51 pm

Thank you and goodnight :-)


Return to “Animation discussion”

Who is online

Users browsing this forum: No registered users and 0 guests