Shared libraries error

Discuss creation of synfig packages and other packaging issues
User avatar
KazAugustin
Posts: 3
Joined: Fri May 10, 2013 12:39 am
Location: Malaysia
Contact:

Shared libraries error

Postby KazAugustin » Fri May 10, 2013 12:48 am

Firstly, thanks to those devs who put together an all-in-one package for Synfig. This is my first attempt at playing around with any animation package so the intent is very much appreciated.

I tried installing 0.63.05 on my 64-bit machine. I'm using Chakra Linux 2013.03 It's beautiful and fast and I'm liking it a lot. When I run synfigstudio, however, I get the following message:

Code: Select all

/home/ksa/Applications/synfigstudio-0.63.05-20120409.master.8.x86_64/bin/synfigstudio: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory


Chakra is as pure a Qt environment as you can get and I don't have a CLUE what libpng12.so.0 is. Is the problem GTK-related?

Kaz Augustin
---
KS "Kaz" Augustin
Personal blog: http://blog.ksaugustin.com

Advertisement

User avatar
Genete
Site Admin
Posts: 5155
Joined: Sat Dec 01, 2007 6:26 am
Location: Spain

Re: Shared libraries error

Postby Genete » Fri May 10, 2013 2:45 am

Hi KazAugustin, welcome to the forums.

Code: Select all

/home/ksa/Applications/synfigstudio-0.63.05-20120409.master.8.x86_64/bin/synfigstudio: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Are you using the universal binaries?
If so, could you run the synfigstudio executable at the top of the unpacked folder?
For more information read this issue:
http://www.synfig.org/issues/thebuggeni ... issues/402

-G
Synfig needs your help!
Developers, packagers, bug testers, translators, artists, web developers, wiki writers... you can contribute! :D

User avatar
KazAugustin
Posts: 3
Joined: Fri May 10, 2013 12:39 am
Location: Malaysia
Contact:

Re: Shared libraries error

Postby KazAugustin » Fri May 10, 2013 3:03 am

Hi G!

Thanks for the welcome. Yes, I used the universal binaries. And I originally ran it from the top-level directory; i.e. not /bin. No dice. Went into /bin, y'know just to be sure, and I got the error referenced in the thread you linked to above. So can confirm that my problem is not QUITE that one.

Interestingly, when I did a "whereis" on libpng, my system tells me that libpng15.so is located in /usr/lib. Note that this is libpng15 and the error msg I'm getting is about libpng12. Could we be talking about some version incompatibility issue here? Just throwin' things out there! ;)

Kaz!
KS "Kaz" Augustin
Personal blog: http://blog.ksaugustin.com

User avatar
Genete
Site Admin
Posts: 5155
Joined: Sat Dec 01, 2007 6:26 am
Location: Spain

Re: Shared libraries error

Postby Genete » Fri May 10, 2013 5:58 am

Yes, it is possible that there are conflicts with the libraries.
Please open a bug issue for that case and be patience meanwhile we fix it. Not planned in a short term, but well.

Alternatively you can compile the binaries yourself. Please wait until we release 0.64.0 (in a few hours or days) and download the tarball and do the classic "./configure && make install"

Cheers!
-G
Synfig needs your help!
Developers, packagers, bug testers, translators, artists, web developers, wiki writers... you can contribute! :D

User avatar
KazAugustin
Posts: 3
Joined: Fri May 10, 2013 12:39 am
Location: Malaysia
Contact:

Re: Shared libraries error

Postby KazAugustin » Fri May 10, 2013 6:37 am

Okay, I'm in no rush. Just thought I'd do some part-time upskilling! :)

I might try compiling the source and see what happens. If I still get the same error, I'll open a bug issue.

Kaz!
KS "Kaz" Augustin
Personal blog: http://blog.ksaugustin.com

KonstantinDmitriev
Site Admin
Posts: 1024
Joined: Thu Jan 10, 2008 2:16 am
Location: Russia
Contact:

Re: Shared libraries error

Postby KonstantinDmitriev » Fri Aug 23, 2013 7:44 am

OK, looks like we have to bundle libpng into our binaries. Please open bugreport for that.

KonstantinDmitriev
Site Admin
Posts: 1024
Joined: Thu Jan 10, 2008 2:16 am
Location: Russia
Contact:

Re: Shared libraries error

Postby KonstantinDmitriev » Sat Aug 31, 2013 2:32 am

I have fixed issue in the latest development snapshots - http://download.tuxfamily.org/synfig/packages/binaries/
Please test and report if it works fine for you.


Return to “Packaging”

Who is online

Users browsing this forum: No registered users and 1 guest