[SOLVED] Link to Spline question

Questions and answers about animation with Synfig. We encourage you to document your findings on the tips page of the website
daria
Posts: 2
Joined: Tue Jun 28, 2016 12:13 pm

[SOLVED] Link to Spline question

Postby daria » Sat Jul 02, 2016 12:18 pm

Hi all,
I am trying to complete my first animation ever, it's heartbeat monitor (EKG). Basically it's a green dot that leaves a track similar to hear rate curve on black background.
I've followed instructions in these topics from forum (creating spline, linking object to spline, moving width points, animating them):
http://www.synfig.org/forums/viewtopic.php?t=4854
http://www.synfig.org/forums/viewtopic.php?t=3455
http://synfig.org/forums/viewtopic.php?f=3&t=2901
and succeed to create basic animation, but I have difficulties linking dot to the final spline, it jumps up and doesn't want to merge with origin of the curve. I've tried the same operation with line that had less vertexes and it worked just fine.
Would you please help me to solve this issue?
I should admit that I am still completely new to Synfig, its logic and ideas behind and have never worked with animation before (yet I work freely with Inkscape).
Thank you all in advance!
Attachments
slow_w_dot.sifz
(3.07 KiB) Downloaded 73 times
Last edited by daria on Sun Jul 03, 2016 4:06 am, edited 1 time in total.

Advertisement

User avatar
Majkel
Posts: 54
Joined: Sun Jun 12, 2016 8:57 am
Location: Poland

Re: Link to Spline question

Postby Majkel » Sat Jul 02, 2016 5:18 pm

Hello,
The problem was that you moved all green line with position handle (that little green circle). You need to delete that green line and create new, link circle to spline, if you want to move it without broking better group circle and line and move a group.
I hope i helped you, i give an example.
slow_w_dot.sifz
(4.21 KiB) Downloaded 71 times

daria
Posts: 2
Joined: Tue Jun 28, 2016 12:13 pm

Re: Link to Spline question

Postby daria » Sun Jul 03, 2016 4:05 am

Hi, Majkel,
Thank you very much for answer and example, it helped!
I reset origin values instead of deleting line, linked to spline, grouped and then moved to the right place.


Return to “Animation related help”

Who is online

Users browsing this forum: No registered users and 2 guests