Synfig Project Forum

Forums for Synfig Project
It is currently Wed Jul 30, 2014 1:59 am

All times are UTC - 4 hours [ DST ]




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 24 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Tue May 18, 2010 2:17 am 
Offline
Site Admin
User avatar

Joined: Sat Dec 01, 2007 7:23 pm
Posts: 988
Location: West Coast USA
https://sourceforge.net/projects/synfig ... e/download

Windows RC2 posted

FFMPEG updated to something more modern. (but still need to include the licenses)
Text box fixed so that default fonts work without explicit reference to the fonts dir.
Dialog boxes are looking good, but I'm still waiting for the dual random splashscreens.
When using the mirror tool the 'toggle horizontal/vertical' by pressing the shift button doesn't 'stick'. It will switch back once the shift is released. Or if the shift key is held down, will toggle back and forth rapidly.

Chris


Top
 Profile  
 
PostPosted: Tue May 18, 2010 3:51 am 
Offline
Site Admin
User avatar

Joined: Sat Dec 01, 2007 6:26 am
Posts: 4750
Location: Spain
Hey pixelgeek,
it is great the fixes for ffmpeg and text font. Regarding to Text fonts, have you done any change to the source code (including configuration files) or is it just a pre configuration issue?
I confirm the bug with the Mirror tool and also I add a bug with the Width tool: when you click and drag it doesn't work. In windows it works when you click and release click so it is not the same behaviour than in linux.
Reset windows to original configuration doesn't take account the bottom application bar but this is an issue of the windows manager. In Gnome (I assume the same in KDE and others desktop managers in linux) the window manager moves the window to a place where it is completely visible. Commands are the same for both linux and windows versions and behavior is different because of the windows manager behavior.
There is a weird bug too regarding to dual splash screen. I think it is the same problem than the windows position and sizes. for some reason the [0-1) float interval conversion to integer always gives 0 in windows. I'll do some modifications for that code but I can only make work it in linux, so, please rebuild the windows binaries again when I release the final candidate this wednesday.
Thanks!
-G
PS: ah! and I still seeing the "rendering in the same thread" console message. I thought I commited that change :oops: Need to re-verify.

_________________
Synfig needs your help!
Developers, packagers, bug testers, translators, artists, web developers, wiki writers... you can contribute! :D


Top
 Profile  
 
PostPosted: Tue May 18, 2010 10:27 am 
Offline

Joined: Fri Aug 21, 2009 3:39 am
Posts: 187
Location: ♥ Oblivion! ♥
Genete wrote:
... I confirm the bug with the Mirror tool and also I add a bug with the Width tool: when you click and drag it doesn't work...

Really? i tested both and they do work, is this a bug exclusive of Windows's build?

_________________
Image


Top
 Profile  
 
PostPosted: Tue May 18, 2010 5:39 pm 
Offline
Site Admin
User avatar

Joined: Sat Dec 01, 2007 6:26 am
Posts: 4750
Location: Spain
H13N.H3N wrote:
Genete wrote:
... I confirm the bug with the Mirror tool and also I add a bug with the Width tool: when you click and drag it doesn't work...

Really? i tested both and they do work, is this a bug exclusive of Windows's build?

In the previous post I was talking just about windows build. (tested on Windows XP)
-G

_________________
Synfig needs your help!
Developers, packagers, bug testers, translators, artists, web developers, wiki writers... you can contribute! :D


Top
 Profile  
 
PostPosted: Tue May 18, 2010 6:00 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 21, 2009 2:36 pm
Posts: 728
Location: Sweden.
Been testing 0.62.01rc2 a bit but haven't found anything disturbingly wrong. Will test more indepth over this week and report anything I'll come across.

Ubuntu 9.04, 64bit.

_________________
www.rylanderanimation.se
Synfig scripts, etc.


Top
 Profile  
 
PostPosted: Tue May 18, 2010 7:08 pm 
Offline
Site Admin
User avatar

Joined: Sat Dec 01, 2007 7:23 pm
Posts: 988
Location: West Coast USA
genete -
Quote:
PS: ah! and I still seeing the "rendering in the same thread" console message. I thought I commited that change :oops: Need to re-verify.

You did, but not in the version tagged as RC2. :)

I still need to try out nikitakit's latest changes.


Top
 Profile  
 
PostPosted: Wed May 19, 2010 11:19 am 
Offline
Site Admin

Joined: Mon Feb 16, 2009 5:19 pm
Posts: 218
pixelgeek wrote:
When using the mirror tool the 'toggle horizontal/vertical' by pressing the shift button doesn't 'stick'. It will switch back once the shift is released. Or if the shift key is held down, will toggle back and forth rapidly.


I implemented the shift key in mirror tool exactly the same way as in normal tool. So if you think it not sticking is a problem, I could easily change that - the question is which functionality is best for the artist. Now the rapid switching is a bug, but on my machine, pressing shift only sends one keyboard event. Apparently this is another one of those Windows-only problems.


Top
 Profile  
 
PostPosted: Thu May 20, 2010 7:13 am 
Offline
User avatar

Joined: Sun Aug 16, 2009 12:09 pm
Posts: 213
Location: Belgium
nikitakit wrote:
pixelgeek wrote:
When using the mirror tool the 'toggle horizontal/vertical' by pressing the shift button doesn't 'stick'. It will switch back once the shift is released. Or if the shift key is held down, will toggle back and forth rapidly.


I implemented the shift key in mirror tool exactly the same way as in normal tool. So if you think it not sticking is a problem, I could easily change that - the question is which functionality is best for the artist. Now the rapid switching is a bug, but on my machine, pressing shift only sends one keyboard event. Apparently this is another one of those Windows-only problems.


confirmed bug in RC3 on windows XP: shift is not sticking so you gotta keep it pressed... and doing so leads to infinite H/V toggling. not exactly usable.
B.


Top
 Profile  
 
PostPosted: Thu May 20, 2010 6:01 pm 
Offline
Site Admin
User avatar

Joined: Sat Dec 01, 2007 7:23 pm
Posts: 988
Location: West Coast USA
We had a good chat about that in IRC last night. There is a quick and dirty solution, but nikitakit is going to look at a more elegant solution this weekend.

Chris


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 24 posts ]  Go to page Previous  1, 2

All times are UTC - 4 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group